--- In David Hawkins <> wrote:
> If TS have found that a specific assembly instruction
> is required, then you may want to rename their PEEK
> and POKE as fpga_in_le16(), fpga_out_le16(), or 'be' if
> the processor is running in big-endian mode (I forget).
> At least then the code will look more standard than
> with PEEK and POKE scattered through-out.
That's a really good idea. The thing that bothered me the most is
that some memory locations were pointers and some were unsigned long
(for the PEEK/POKE stuff). So, being more familiar with pointers, I
tried to convert everything to pointers.
Maybe I need to remember the goal.... To simplify the code and make
it maintainable, not to make everything a pointer....
Heck, I think I'll rewrite the PEEK/POKE stuff to use a ((void
*)memloc, uint16_t offset, uintXX_t value). That would make things
much cleaner.
:-)
--Yan
Yahoo! Groups Links
<*> To visit your group on the web, go to:
http://groups.yahoo.com/group/ts-7000/
<*> Your email settings:
Individual Email | Traditional
<*> To change settings online go to:
http://groups.yahoo.com/group/ts-7000/join
(Yahoo! ID required)
<*> To change settings via email:
<*> To unsubscribe from this group, send an email to:
<*> Your use of Yahoo! Groups is subject to:
http://docs.yahoo.com/info/terms/
|